Can limit switches work during normal operation as well as when homing?

Hello I wonder if I could bother you please with a GRBL LPC Question, I realise I might need to provide you with more info and if you tell me what is needed I will find out.

I have been running quite well a Stock original K40 analog version on a MakerBase MKS V1.3 card for about 9 months now without any serious problems.

There is just one thing that is bugging me and its to do with the limit switches.

I use lightburn as my controller running on Windows 10, When I use lightburn to home the laser goes back to the 0,0 point perfect well but if I operate the micro switch separately that particular axis will not stop, the switch is working and nothing happens, the same goes for the other axis as well,

The switches are plugged into the first port and second port on the board for the limit switches running 2 wires to each switch.

Homing is working fine but individual press on the switch does nothing. Is this correct please and if so can it be fixed at all so that if a switch or both the switches are tripped the head will stop, we would like this to be on each end of the axis so 4 switches in total.

Im sorry but I do not know virtually anything about GRBL LPC as I am not a coder or programmer but lightroom I know reasonably well and I have been using this laser now for about 9 months without problems.

Is this something you could help us with please.

We are in the process of building a much larger C02 laser running on the MKS card about 1 metre square base and I would like if possible for the micro switches all to work. I just dont know if its possible.

Many thanks for any help

Neil Scott, Sitges, Barcelona Spain.

I do not recommend using the hard limit configiration. Triggering a hard limit forces grbl into an alarm state (like immergency stop) which is not easy to get out from. Instead I recommend configuring homing with soft limits, with maximum travel distances a little shorter than the axes limits. This way grbl can detect moves that would go beyond the limits and would not execute them (+ warn you).

Best would be, if the host software also handles the maximum machine space and warn you before you run something that is too big for your workspace.

1 Like

Be aware that by default grbl uses two different coordinate systems (with separate origins). One is the machine coordinate system, whose origin is set by the homing procedure. The other is the work coordinate system, where you can set the origin at the wished location by executing a work offset command (G10).

You can select work coordinates in the position responses from the controller by setting $10=0.

Thank you for your detailed replies Claudio, Im sorry I have not got back to you before but I have been a little unwell and stayed in bed until today. Still not 100% but should be soon and will take alook at everything you have said.

thank you for your fast response.