Can I get a gut check here?

fastled-support
gplus
(Christopher Kirkman) #1

Can I get a gut check here? Before I climb up 15 feet to pull the strip down, can anyone offer an educated guess as to why my strip would be doing this:

Google Photos

300 pixel strip, 5v 15a power supply running FastLED on a Photon Particle. It lights up the first 200 or so with whatever pattern or color I throw at it, then ~24 are just dead, then the rest light up however they feel like it.

I’m pretty confident it’s not the sketch. Maybe it’s a power issue? If it were a bad connection in the strip, is there any explanation for it still lighting up those on the far end like that? (first pixel is on the far right, not pictured). I’ve got a capacitor on the circuit and followed best practices. I’d hate to have to pull out a ladder only to find it was something at ground level I could have fixed.

(Thomas “Balu” Walter) #2

Common ground for Particle and strip?

(Christopher Kirkman) #3

@Thomas_Balu_Walter yessir

(Yves BAZIN) #4

@Christopher_Kirkman1 just to be sure could you post your code on gist :slight_smile: another look can’t hurt.
What kind of led are you using ?

(Christopher Kirkman) #5

Sure thing:

And the strip I’m using:

Quick note: the actual number of LEDs in the strip is 301, so when you see that, it’s not a typo. I was using this circuit initially with a different setup, so there’s an extra LED in the sequence on the board before it gets to the strip.

I swear I had this running last year for the holidays but something changed between now and then, I just don’t know what.

(Yves BAZIN) #6

@Christopher_Kirkman1 does the issue occurs with all the ‘patterns’ ?

(Christopher Kirkman) #7

@Yves_BAZIN Yes. I can switch back and forth and the rest of the strip responds, whether it’s one of the gradient palettes, fireworks or just a solid color. Twinkles too. I just turned it on for the first time in a while, so I haven’t tried to dump the sketch and try something simple yet (on my to dos for tomorrow).

(Yves BAZIN) #8

@Christopher_Kirkman1 I am not sure I understand correctly. What do you mean by the rest of the strip responds ?
If a simple fill_solid doesn’t work. I am afraid that a led may be down

(Daniel Haber) #9

Seems like you might have to cut out the first LED that won’t turn on and put a new LED in there. Or just slide the whole strip down.

(Mark Estes) #10

before you cut, try adding a bit of solder to the cut location between the last working pixel and the first bad boy. could be a simple open in the data line. while you are at it, check to see if you have ground and power on the non working leads. lastly, you can test to see if the pixel is bad by bridging the data line around it temporarily .

(Daniel Haber) #11

@Mark_Estes those are some good suggestions that hopefully I’ll remember!

(Christopher Kirkman) #12

So yeah, looks like I might need to pull out the ladder. I’m gonna try a new, dead simple sketch to test one last time.

(juraj olsavsky) #13

I had similar thing doing on less leds, if you have another/different arduino try to load sketch or what board you running fastled on, try it with another board, in my case that fixed issue…

(Christopher Kirkman) #14

UPDATE: I pulled the strip down and discovered that the waterproofing looked like it had been chewed away a bit and the ground solder was broken at the point just before the section where it blanked out. I reinforced all three solder joints.

That solved the dead area, but the weird random color flashing still happens around the 270 mark. I uploaded a basic sketch where I type in a number and it lights that single pixel to eliminate most of the other variables. Still happens even though the sketch is telling it just one LED should be lit. So I’m about ready to pull back the waterproofing and break out the multimeter to narrow it down further.

(juraj olsavsky) #15

Try different board…

(Christopher Kirkman) #16

That’s easier said than done, but I’ll add it to my troubleshooting list. Is there a specific reason to believe another board would solve it? Other than a defect, like memory or power?

(juraj olsavsky) #17

I don’t have a clue, but I was working on ambilight project for my telly, set it up on trial basis and was great, packed it up, put it on shelf, few weeks later I go to play with again no luck. Couple of leds at the end having random colour and strip as whole not responding to serial communication, as it worked before with arduino atmega 2560 suddenly it didn’t… Tried number of sketches, reduces number of less in leds in sketch, unassigned leds still showing colour, changed board to uno suddenly all worked as it should…

(Christopher Kirkman) #18

Weird, well the reasons I don’t immediately try is that the circuit I built is meant specifically for this Photon board and I don’t have a spare, so it means finding a spare Uno and rewriting the sketch a bit to accommodate for it. Doing that also means, at least temporarily losing WiFi functionality

(juraj olsavsky) #19

I don’t know what was wrong with it, I’m by no means knowledgabe enough to advise, if you have sketch try change number of leds (total minus how many show wrong) upload, refresh, see if they are still lit…make sure it really is leds before you go with scissors on strip, if they not being addressed these last few less shouldnt be showing anything…thats my idea anyway…

(juraj olsavsky) #20

Auto-correct keep changing leds for less…sorry