Bulid error

smoothie-forum
(redpiperbob_SW) #1

Hi everybody
Just waiting for my Smoothieboard to arrive . So I thought I would download the firmware and build it but I get the following error “make: [all] error 2”
This site will not let me add a pic to this message.
has anyone any ideas.
Thanks
Bob

Imported from wikidot

(Arthur Wolf) #2

Hello !

Did you build the toolchain using one of the install script, and then run the BuildShell script ?

Cheers.

(redpiperbob_SW) #3

yes I did I tried Smoothie-edge.zip and smoothie-master.zip
Bob

(Arthur Wolf) #4

Can you give us the full output of make ?

(redpiperbob_SW) #5

this site will not let me post a url to the screen shot I do not know how to get the image to you
Bob

(Arthur Wolf) #6

You can email it to wolf.arthur@gmail.com, I will post it here.

(Arthur Wolf) #7

http://s290.photobucket.com/user/redpiperbob/media/CNC/builderror.png.html

It looks like you are missing a file, can you try cloning the git repo again and installing the toolchain again with the install script ?

(redpiperbob_SW) #8

OK started from scratch but got the same error
Bob

(redpiperbob_SW) #9

Hi Arthur
Just dug out an old Windows XP 32 bit machine and ran the same zip file (Master) and all went well.
I can only think there is something in the build of my Win 7 64bit that was blocking or deleting the missing file.
Just waiting for the board from Ipso now to get on with my laser project.
Thanks for your help anyway.
Bob

(rdacomp_SW) #10

After make getting the message. OS Windows 8.1 32 bit

E:\Smoothie>make
make[1]: Entering directory ‘E:/Smoothie/mbed’
Building src
make[2]: Entering directory ‘E:/Smoothie/mbed/src’
Deploying cpp/AnalogIn.h to drop
“C:/Program Files/Git/bin/sh.exe”: copy: command not found
make[2]: * […/drop/AnalogIn.h] Error 127
make[2]: Leaving directory ‘E:/Smoothie/mbed/src’
make[1]: *
[src] Error 2
make[1]: Leaving directory ‘E:/Smoothie/mbed’
make: *** [all] Error 2

(Wolfmanjm) #11

Make sure you have a clean PATH environment setting, you probably have something in your path, usually winavr, that is upsetting things.