Beginners Help

This comment “but it seems to mirror how the machine spits out my work when I set it that way” assures me it’s a configuration issue. Been there, done that… :frowning: One of the parts your data is flowing through is referencing a different ‘home’ or absolute 0,0 position. If it’s only Lightburn and your laser, one of them is mis configured. Don’t need to know about switches, it’s where the head homes. On power up it ‘heads’ (both x and y) to the limit switches. This is in the configuration of a ‘homing’ direction on the controller.

When you power up your machine, it will ‘home.’ Pick that corner. BACKUP you original configuration before modifying ANYTHING. If it’s not too late.

The machine defaults to certain positions, setup by the manufacturer for it to operate with accompanied software. The software has to be configurable to take into account where the home position is, or absolute coordinates of 0,0. Don’t try and modify the internals until you get the ‘hang’ of what you’re doing. You’ll just drive yourself nuts.

I have always found that when some kinds of image reversals or something similar happen, it’s a configuration issue. If you haven’t modified the machine or it’s firmware, the software must be the culprit. That’s a good starting place.

Another thing I found, thinking something works one way when it doesn’t. If possible read the documentation. All of the ‘buttons’ and ‘check boxes’ are in the documentation for lightburn.

Good luck. Take care…

1 Like

Mike, can you verify that the corner you picked in your Edit->Device Settings->Origin is the same corner you picked when you created your machine device type AND it’s a good idea to have the Auto-home on startup option turned on too. They should show the same as they are probably associated but good to check and making sure the machine goes to Home position when the controller powers up and when LightBurn connects is a good idea. Because if the home position is not consistent then designs will not show up where you or the software expects them to be.

There are both a Home position and Origin elements to deal with but I keep them the same most of the time. ie on my K40/Smoothieware the home position is top/left and my Origin is set to Absolute Coords so I see the little green dot/box in the top/left and the little red dot/box in the same corner.

If I set the Origin to User Origin type with the center radio button selected then you’d see the origin green dot move to the center of your work area. You can also set user defined origins with Set Origin and Clear Origin buttons and I will do that sometimes when I’m repeating an etch. For example I cut out Xmas bulbs and had a stack of blanks, I place a template on my work area with magnets and set the origin to the center of the bulb. Then I change to Current Position type of origin. Now when I hit GoTo Origin it will always go to the center of the bulb and my design will start burning there.

ok, I did some more reading and it sounds like I put the wrong smoothie ware onto my cohesion mini board.

So, I have decided to go back to GRBL-LPC as that is what was working. I downloaded the new v1.1 version here: grbl-lpc C3D Mini Firmware Builds – Jim's Embeddedtronics I took the 4 axis bin as I am thinking that is what I needed?

Flash it in, fire up the machine and it won’t home in lightburn. I get the alarm 8 Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.

Now, when I had smoothie in it would move around when I asked it to go home, so I know the wiring is fine.

Does anyone have a config file for GRBL-LPC for the K40? my bet at this point is I have a bunch of settings off…

Why 4 axis? The K40 only has X and Y axis. Since you installed firmware for 4 axis it is probably looking for homing switches for the non-existent axises.

Also, why did you not get the K40 firmware from
K40 with M2Nano Cohesion3D LaserBoard Installation Guide - Cohesion3D

Because I am having a hard time finding information and I can’t get any responses on the C3d board so far.

That link you sent seems to talk about smoothieboard software and I am not sure if the nano board is the mini board.

At this point I know laser GRBL was what was on there when I bought it from the guy and I just want to go back to what it had and try and work from there. Ive probably spent 30+ hours trying to figure out firmware stuff, I just want to start using my laser. I am confused and frustrated at this point

That guide is for replacing the M2Nano with the Cohesion3D board.

There is no configuration file for grbl-lpc of any flavor. It only uses $ commands sent to it to configure it.

I reinstalled smoothie and I can jog my laser around. I put GRBL back on and am having issues.

I found an earlier version of a 3 axies GRBL-LPC on cohesions site, so I put that on.

Here are my machine settings:










































I can’t home and when I point the laser it acts funny around the bed not always going where expected.


Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.


Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]


I am at the point I am going to set this thing on fire in a minute…

you need to get it to home correctly and only then would I even start trying to move around the bed. MAYBE I would move 5mm and see if it moves in the right direction and by the correct amount so I know my steps/mm are correct and my motors are wired correctly. But you have to get it to home and trigger the 2 limit switches.

What software are you using to control you laser? Often the software will put labels on those settings you listed so you know where to look. I’m going to post one of my ocnfig files for a GRBL laser just so you see the comments and can understand what those numbers you have in your machine mean and maybe if they are correct.

$0=20 (Step pulse time, microseconds)
$1=50 (Step idle delay, milliseconds)
$2=0 (Step pulse invert, mask)
$3=1 (Step direction invert, mask)
$4=0 (Invert step enable pin, boolean)
$5=0 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$10=1 (Status report options, mask)
$11=0.050 (Junction deviation, millimeters)
$12=0.002 (Arc tolerance, millimeters)
$13=0 (Report in inches, boolean)
$20=1 (Soft limits enable, boolean)
$21=1 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=7 (Homing direction invert, mask)
$24=600.000 (Homing locate feed rate, mm/min)
$25=3000.000 (Homing search seek rate, mm/min)
$26=100 (Homing switch debounce delay, milliseconds)
$27=2.000 (Homing switch pull-off distance, millimeters)
$30=1000 (Maximum spindle speed, RPM)
$31=0 (Minimum spindle speed, RPM)
$32=1 (Laser-mode enable, boolean)
$100=80.000 (X-axis travel resolution, step/mm)
$101=80.000 (Y-axis travel resolution, step/mm)
$102=80.000 (Z-axis travel resolution, step/mm)
$110=9000.000 (X-axis maximum rate, mm/min)
$111=9000.000 (Y-axis maximum rate, mm/min)
$112=9000.000 (Z-axis maximum rate, mm/min)
$120=2200.000 (X-axis acceleration, mm/sec^2)
$121=1800.000 (Y-axis acceleration, mm/sec^2)
$122=2500.000 (Z-axis acceleration, mm/sec^2)
$130=160.000 (X-axis maximum travel, millimeters)
$131=150.000 (Y-axis maximum travel, millimeters)
$132=1.000 (Z-axis maximum travel, millimeters)
[GC:G1 ```

Sorry, I forgot that Ray at Cohesion has been out at MRRF show and not responding to forum posts. I saw he just started responding last night. I don’t have GRBL-LPC on my K40 so I can’t share a config file but I do have a smoothieware bin file and config.txt file if/when you want to try that.

But many of us have GRBL based machines too so we can probably get you running again but it will take more time since as was pointed out, GRBL is configured with $ commands and some of them are instructions to save to flash.

This is commonly from needing to invert sense for the limit switches. You have $5=1 — should it be $5=0 perhaps?

I am game to try anything at this point. If you want to email them to me that would be great. I think I just sent you a PM.

Mcdanlj I just tried putting $5-1 and it smashes the laser into the top of the machine and then shakes going left to right. It eventually hits the switch and then throws an alarm 9


Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.


Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

So a bit of progress…

I sent you the files but in hindsight, you really need to stick with what once worked until you learn more about these things. The K40 is a VERY inexpensive laser but it is not a consumer grade machine and is 100% a DIY machine. It’s cheap but it is cheap for a reason.

I gotta ask, why did you even try to install Smoothieware on it when you already had GRBL-LPC installed and configured?

Thanks. As for why, I bought the machine used already set up. I went to use it and it was kind of acting a but funky bouncing off the gantry. I had seen the guy make a test circle when I picked it up, so I knew it worked, but didn’t know if there were bugs. I immediately thought if I update it to the newest firmware it would be a good idea. I saved what was on the sd card not realizing that I can’t just revert back. I had also read that smoothie was a bit better, but I really didn’t know why.

So I made a rookie mistake and shot myself in the foot thinking it was a good thing to do. I don’t have a programming background, so I am trying to learn while spinning my tires here.

I appreciate the files, I’ve switched back to smoothie, hoping to God I can sort this out. It worked best with my origin top right, but every job I tried started going to different areas.

Some thing is really wrong if it was erratic with GRBL-LPC and erratic with Smoothieware. There are lots of long wires moving around, some are end stop wires and some are stepper motor wires. I hope it’s something like that as opposed to a cracked circuit board.

And I would be doing nothing but drawing straight lines and trying to figure out what is causing the erratic behavior. ie no laser power at all, turn the laser off on the front panel and just do things like try to get it to go home repeatedly. ie turn the C3D off and move the laser head to the center of the bed then power it on and watch it home. Repeat it many times until you know it will always do that no matter where the laser head starts. Then draw a line diagonally from where ever LightBurn thinks the laserhead is to the center of the bed and setup the Device to go home when done.

You have to get this to repeat movements or figure out what failures are causing it to not repeat the commands. Trying to make something is wasting time until the machine is stable.

Also, if you backed up the uSD before you put C3D stuff on it, then you should have the GRBL-LPC config and firmware. There should have been a file on the uSD called FIRMWARE.CUR and that should have been a backup copy of the GRBL-LPC firmware.bin file.

You might not have the customizations but those can be worked through. Regardless, you have something electrically wrong with the machine and that needs to be figured out before dealing with firmware changes. The are called CNC machines because they repeat the commands they are told to execute… You machine does not do this, ie it does not reliably repeat commands and that needs to be fixed.

This is the plan and laser has been off other than when I was getting mostly repeatable results with origin set in upper right. Then all of a sudden it was not repeatable so laser went off and I have been trying things and doing “dry runs” meaning no laser, do what I say and repeat.

C3D is saying they discontinued mini boards so they have limited support. Smoothirware is newer than grbl so they have suggested going to that.

As far as the grbl files, they switched over to .CUS so I can’t access anything in them. There are not external config files for grbl

1 Like

Cohesion got back to me and provided me with a link to the proper files for the mini cohesion board that I have. So I installed the config file and batch 3 files directly from their link.

At first I was excited as it appeared it may be working. The first few points I told the machine to move with the laser point in lightburn the machine listened. After that it stopped responding where I told it to go. Here is a video of what it is doing here:

For the record you are seeing the video as I call the laser positions. Upper left is upper left of the screen. It starts out great, then goes haywire.

When I hit “home” the laser head moves only a few inches and stops.

I tried testing the end stops / homing sensor following the instructions here: Testing Endstops/ Homing Sensors on LaserBoard - Cohesion3D
and this is what I got:

When doing M119 command I got the following with the laser as close to the middle of the board as I could get it: X_min:1 Y_max:1 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 (Z)P1.28:1 (Z)P1.29:1

When touching the Y pin I get: X_min:1 Y_max:1 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 (Z)P1.28:1 (Z)P1.29:1

When touching X I get this: X_min:1 Y_max:1 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 (Z)P1.28:1 (Z)P1.29:1

I am not sure what this means? Potentially a bad wire or switch issue? how can I diagnose? I am not sure what was working when I bought it, the owner did a quick demonstration for me, but I also watched the laser slam the gantry a few times before he drew a circle in the middle of the bed.

Also can a bad wire/switch for end stops/homing switches cause the laser not to manually move where directed?

Doug, I looked at their config file vs yours and there are definitely differences. As I want to try and isolate things I used their config file first without making any changes.

I am going to compile the differences in the file this weekend and post here which they are.

I am also going to take a ton of photos of the board and compare it to the install guide for cohesion. All the connections look solid at this time.

your machine messed up when you told it to move to the left of center and it moved right. End of test right there IMO. What caused that is what needs to be figured out.

As for those switch testing, do you see any changes in the output when you trip the limite switch? I don’t see any change so either you didn’t trip the limit switch or something else is wrong. You do have to trip and HOLD the limit switch while then running the M119 command as it does not show the past or the future, just what the current switch positions are.

Looking more and more like at least one of my issues is a homing switch problem as I have inducter ones.

It has been suggested that I switch to manual homing switches. Are these ones ok to use? What is involved in installing them?

Is there a harness I can buy already prefabbed? If not, where can I buy the clips that allow me to plug into the board?

Again this is for a cohesion board- I have the same question posted on their forum as well awaiting an answer: