Autolevel not working after update

Good afternoon Ladies and gents,
Long time reader first time poster. We have had our Tevo Little Monster for a little over a year now, originally it had one of the MKS base garbage boards which was replaced with an Azteeg X5 GT and viki2 LCD which we are running now. last time it was updated was several months ago with the latest smoothie build and latest config at that time. I had never been able to get the auto level to work consistently and would have to manual level the print bed with shims and what not. Every time i would run the auto calibrate script on the LCD display it would home, reset the BLtouch probe, heat bed, run through its calibration with no problem, complete and re-home. I would then adjust the z offset and start printing adjusting for the probe offset. It was never 100 percent accurate but it worked for what I was printing even though the first layer was never even and jacked up a little. Fast forward to last week now that I have time to work on it again. I updated the firmware.bin file from the github repo, copied over the new config from the same repo and then matched all the changes from my current config to the new config. Got everything working, home stepper motor direction, extrude setup and set up for the heated bed and hotend. Tested the BLtouch probe and all commands work as they should but when running the auto level script the probe moves to the direction of the alpha tower probes and while its moving to the beta tower it smacks the glass bed in between the alpha and beta tower. This process repeats and it again probes the beta tower and smacks the glass moving onto the gamma tower. It then homes and the process repeats itself over and over again, it did it 6-7 times before i stopped it by cutting off the power. I have reformatted the sd card, replaced the sd card, re downloaded and installed fresh firmware and config files and reported everything twice. Im pretty sure its my mistake somewhere but I simply cant figure out where, if you can point me in the right direction it would be greatly appreciated. I am attaching my config and a vimeo video of whats happening. I tried printing by skipping the auto leveling and just setting the z height but that also does weird stuff where the hotend moves up and down like a snake while its extruding the first layer.

video

config
https://pastebin.com/embed_js/qu6qJZBq

That video link fails. Can you please describe your problem in text in any case? Video should be to help understand, but please provide details in text.

sorry about that video has been corrected. Printer does not probe in a grid pattern, it does a 3 point level which is ok if it worked. problem is when its moving location it does not lift the z axis and just proceeds to scrape the bed when doing xy movements as if it thinks its a Cartesian printer. I am unsure what caused this as the leveling strategy is the same that I used with the last firmware as is the custom menu entry.

1 Like

Do you know what gcode is being run as the “auto calibrate script”?

Do you know more precisely what version of smoothieware you were running before the update? Do you have the old configuration file as well as current?

(I’m not a smoothie expert, I’m just trying to make sure that @Arthur_Wolf or someone else with expertise has the necessary information to be able to help for real…)

I have the saved files in a folder on my desktop, the Date modified on the FIRMWARE.CUR is 11/16/2018 I am unsure how to check the version from that.

Old Config-worked
https://pastebin.com/embed_iframe/SWrWJByd

as far as the script, I have tried all of these with the same result;

M280_PS3|G32|G31|M500|M280_PS7|G28|M84 # M280_PS3|M190_S80|G32|G31|M374|M500|M280_PS7|G28|M140_S0|M84|reset# M280_S10.6|M280_S3.3|M190_S80|G32|M500|M374|M280_S10.6|M280_S7|G28|M140_S0|M84|reset#

Here are the meaningful differences between the two configurations. The red lines starting with - are what is in your old configuration, and the green lines starting with + are what is in your new configuration.

I note that the custom_menu.auto_calibrate.command is different

-acceleration 1000 
+acceleration 3000 
-alpha_limit_enable false 
-alpha_steps_per_mm 159.53 
-alpha_trim 0 
+alpha_steps_per_mm 160 
-arm_radius 154.1099 
+arm_radius 170 
-base_stepping_frequency 100000 
-beta_limit_enable false 
-beta_steps_per_mm 159.53 
-beta_trim 0 
+beta_steps_per_mm 160 
-custom_menu.auto_calibrate.command M280_PS10.6|M280_PS3|M190_S80|G32|G31|M374|M500|M280_PS10.6|M280_PS7|G28|M140_S0|M84|
+custom_menu.auto_calibrate.command M280_PS3|G32|G31|M500|M280_PS7|G28|M84 
-custom_menu.bl_down.command M280_S3 
+custom_menu.bl_down.command M280_PS3 
-custom_menu.bl_reset.command M280_S10.6 
+custom_menu.bl_reset.command M280_PS10.6 
-custom_menu.bl_test.command M280_S8.4 
+custom_menu.bl_selftest.command M280_PS8.4 
+custom_menu.bl_selftest.enable true 
+custom_menu.bl_selftest.name BLTouch_Self_Test 
+custom_menu.bl_test.command M280_PS5.5 
-custom_menu.bl_up.command M280_S7 
+custom_menu.bl_up.command M280_PS7 
+custom_menu.calibrate_center.command G0_F8000_X0_Y0_Z0 
+custom_menu.calibrate_center.enable true 
+custom_menu.calibrate_center.name Calibrate_Center 
+custom_menu.calibrate_x.command G0_F8000_X-140_Y-80_Z0 
+custom_menu.calibrate_x.enable true 
+custom_menu.calibrate_x.name Calibrate_X 
+custom_menu.calibrate_y.command G0_F8000_X140_Y-80_Z0 
+custom_menu.calibrate_y.enable true 
+custom_menu.calibrate_y.name Calibrate_Y 
+custom_menu.calibrate_z.command G0_F8000_X0_Y150_Z0 
+custom_menu.calibrate_z.enable true 
+custom_menu.calibrate_z.name Calibrate_Z 
-custom_menu.eject_filament.command G28|G0_F8000_Z100|M42|M109_T0_S240|G92_E0|G1_E10_F300|G1_E-650_F9000|M104_S0|
+custom_menu.eject_filament.command G28|G0_F8000_Z100|M42|M109_T0_S230|G92_E0|G1_E10_F300|G1_E-650_F9000|M104_S0|
-custom_menu.load_filament.command G28|G0_F8000_Z100|M42|G92_E0|G1_E50_F300|M109_T0_S240|G1_E590_F9000|G1_E650_F300|M104_S0|
+custom_menu.load_filament.command G28|G0_F8000_Z100|M42|G92_E0|G1_E50_F300|M109_T0_S230|G1_E590_F9000|G1_E650_F300|M104_S0|
-custom_menu.Z_height.command G0_Z0 
+custom_menu.Z_height.command G0_Z1 
-custom_menu.Z_offset.command M306_Z0 
+custom_menu.Z_offset.command M306_Z0|M500|M84 
+delta_current 0.75 
-delta_segments_per_second 100 
-gamma_limit_enable false 
-gamma_max 519.14 
+gamma_max 500 
-gamma_steps_per_mm 159.53 
-gamma_trim 0 
+gamma_steps_per_mm 160 
-laser_module_enable false 
-leveling-strategy.delta-calibration.radius 150 
+leveling-strategy.delta-calibration.initial_height 25 
+leveling-strategy.delta-calibration.radius 130 
-leveling-strategy.delta-grid.probe_offsets 0,0,0 
-leveling-strategy.delta-grid.radius 150 
+leveling-strategy.delta-grid.probe_offsets 0,25,0 
+leveling-strategy.delta-grid.radius 130 
-leveling-strategy.delta-grid.size 11 
-microseconds_per_step_pulse 1 
+leveling-strategy.delta-grid.size 7 
+network.telnet.enable false 
-panel.gamma_jog_feedrate 250 
+panel.gamma_jog_feedrate 4000 
-planner_queue_size 32 
+switch.fan.output_type pwm 
-x_axis_max_speed 40000.0 
-y_axis_max_speed 40000.0 
-z_axis_max_speed 40000.0 
-zprobe.debounce_count 100 
+x_axis_max_speed 30000 
+y_axis_max_speed 30000 
+z_axis_max_speed 5000 
-zprobe.fast_feedrate 200 
-zprobe.probe_height 5 
+zprobe.fast_feedrate 100 
+zprobe.probe_height 10 
-zprobe.slow_feedrate 10 
+zprobe.slow_feedrate 5 

1 Like

Arm radius would do that, it’ll make it travel not in a straight line between the points and that’s why it’s creating the arcing pattern between the probe points.

1 Like

I did try making changes to the config and see if it made a difference which it didn’t. I also purposefully did not copy over settings that were not present in the new sample config. do I need to do that?

I’m changing the arm radius to a much lower and high number to see if it makes a difference, I have the 3d model of the printer from thingiverse and used that to make the arm radius measurement. The 170mm arm radius measurement comes directly from tevo they extended the ball joints to 400mm in their newer version printers which is what i did. but I am unsure how they came up with 170mm as an arm radius when my measurements don’t come close to that.

Update:

put in the old config file and everything is now working as it should, I’m going to have to peer over line by line over the weekend to see whats different that could be affecting the auto leveling procedure. Thanks for the ideas they helped me better grasp the feature.

2 Likes