Attempting to do a remote flash with 1.83 (and 1.82)  2015/07/20 01:03:14 serial.go:137:

Attempting to do a remote flash with 1.83 (and 1.82)

2015/07/20 01:03:14 serial.go:137: Unregistering a port: /dev/ttyACM0
2015/07/20 01:03:20 hub.go:121: programfromurl /dev/ttyACM0 arduino:sam:arduino_due_x 2015/07/20 01:03:20 download.go:28: The filePrefix is gShield.bin
2015/07/20 01:03:20 download.go:31: Downloading to /tmp/serial-port-json-server002783231/gShield.bin
2015/07/20 01:03:23 download.go:44: 4777 bytes downloaded.
2015/07/20 01:03:23 programmer.go:286: Restarting in bootloader mode
2015/07/20 01:03:23 programmer.go:286: Was able to open port in 1200 baud mode
2015/07/20 01:03:23 programmer.go:286: [/dev/ttyACM0 /dev/ttyACM2 /dev/ttyAMA0]
2015/07/20 01:03:23 programmer.go:286: [/dev/ttyAMA0]
2015/07/20 01:03:24 programmer.go:228:
2015/07/20 01:03:24 programmer.go:228: --port=ttyACM0
2015/07/20 01:03:24 programmer.go:228: true
2015/07/20 01:03:24 programmer.go:228: /tmp/serial-port-json-server002783231/gShield.bin
2015/07/20 01:03:24 programmer.go:286: Tool:/home/pi/serial-port-json-server_1.83_linux_arm/arduino/tools/bossac/bin/bossac, cmdline:[–port=ttyACM0 -U true -e -w -v -b /tmp/serial-port-json-server002783231/gShield.bin -R -v]
2015/07/20 01:03:24 programmer.go:72: Flashing with command:–port=ttyACM0 -U true -e -w -v -b /tmp/serial-port-json-server002783231/gShield.bin -R -v
2015/07/20 01:03:24 programmer.go:99: Command finished with error: signal: illegal instruction

Tried it a couple of times and it comes up with the same error.
Chilipeppr > Programming… Could not program the board.
SPJS > error: signal: illegal instruction

I pulled the Due out brought it to my office and I was able to flash it directly with the method I used in the past.

Hmm. Is that a Pi 1 or Pi 2 you were trying to program your board from?

Tested from both a RPi B+ & RPi 2.

I was able to get it to work via the RPi B+. Seems like whatever you have in the bin/bossac folder will not work on RPi or BBB. I had to use another one and replace the one you provided. (Which took upgrading from wheezy to jesse and downing and recompiling the Arduino IDE (1.6.5)

Oh you may want to put in some kind of verbiage to disconnect CP from the port your are trying to flash or have some kind of logic that disconnects the the port when you enter the flash ‘widget’

Yes, that was a detail I missed. I’m so trained to disconnect I forgot I need to force folks or do it automatically for them.