Anyone have any idea how to fix this??

Anyone have any idea how to fix this??


@Panagiotis_Varonis ​ Means you have either another session of LW open or some other software using the same address. “EACCES:”. Restarting the computer usually solves the issue.

Do you use the latest LW4 version?
This issue was fixed several weeks ago. The new version would just switch to the running application instead of showing the error. Or do you have another application (not LW4) that reserves IP Port 8000?

Yes i have last version, i restart pc several. I close every program, some services but still the same.

@cprezzi ​ I just verified on my windows PC with freshly compiled version. If I npm start from the console and then try to open the desktop app it shows the error still . One I click it opens a white screen

Hm. I only checked it with two Electron EXEs, but not with dev environment and exe. Probably those have different process names so I can’t find out it’s same.

@Panagiotis_Varonis Do you use the installer version or the dev environment (with npm start)?

I use the installer version (.exe x64) and i make a try with the older one LaserWeb3 from console and was the same.

Trying to run 2 copies of LW4 on Mac will autoclose the second when trying to open it

@Panagiotis_Varonis It looks like another app is using port 8000.

You can try this:

  • create a “.env” file with a text editor in the installation folder of LaserWeb4
  • Enter the following text in the file: WEB_PORT=8001
  • Save it and resart LaserWeb4
  • Got to Comms tab and click on “Server connection”
  • Change the server IP from localhost:8000 to localhost:8001
  • Click Connect

Hope this solves your problem!

Unfortunately didn’t, and the error still saying about 8000. When i start localhost the iis7 load, i try uninstall, disable services e.t.c. nothing worked. I am looking it and inform if i find something. Thanks a lot guys.

I have an Apache service that I need to disable before running LW

I started LaserWeb3 with modified file of server.js with 8001 port. I start it from cmd and work fine as i see, is a way to change the port to LaserWeb4 too?

Or maybe a format of my pc will do the trick :frowning:

I have explained the way to change the port for LW4 in my earlier post (.env file without additional ending!).

That should work for the exe or in dev environment.

@cprezzi Yes but didn’t work for me :(. I was wonder if i can do it otherwise.

Just to be sure, i create a file port.env in C:\Users\profile\AppData\Local\Programs\lw.comm-server with just WEB_PORT=8001 inside. Save and start laserweb, right?

No, the file should have the name “.env” only.

If you are on Windows, you probably have to disable “Hide protected system files” and “Hide extensions of known filetypes” in Explorer settings to be able to see such files.

@cprezzi Thanks a lot my friend, i (you) make it work.

Just when i start the application nothing happens, a screen pop up with 404 error and i go in chrome and open localhost.

@Panagiotis_Varonis Thank’s for the hint. I found the error why port changing by .env file is not working in the exe. Should be fixed with the next release.

@cprezzi Keep up the good work, thanks for everything