Alright! I think that I may have found my issue!!  Nathaniel Stenzel ,

3d-faq
3d-qa
3d-help
gplus
(boog nish) #1

Alright! I think that I may have found my issue!! @NathanielStenzel , I went and compared, like you suggested, a good saved gcode which will print now to a newly generated gcode of same model, which will not print now. @Peter_Hertel had thrown the idea out that maybe it was waiting for temp to be reached (M109). What I seem to have found is that with the new gcode it IS waiting for the HEATED BED temp to be reached (M190). I don’t have a heated bed!! So i went into the ‘printer settings’ in Repetier and set my default bed temp to 0- but it still is generated in the Gcode. (The new one is on the right in the picture here, the old one on the left). My old code does not have a M190 line. >>Is what I need to do something like doing a M140 S0, to disable this, and then M500 it?? That seems to be the biggest apparent difference in comparing the old working gcode to the new non-working gcodes… ( there are a few other little differences in some of the values but I think that this heated bed issue is the real problem here… @David_Wille I’d be grateful for your thoughts here too! Thanks!!!

(Nathaniel Stenzel) #2

Is there a spot to tell it if you have a heated bed? Is there a spot to edit the gcode and the beginning and ending?

(Jon Gordon) #3

“b4” ugh you kill me.

(boog nish) #4

Hmm. In repetier there is a blank field, under the ‘Gcode’ tab… Is that what you mean? It has drop down options of ‘Gcode’, ‘start code’, ‘end code’, ‘run on kill’, ‘run on pause’ and ‘scripts’…

(boog nish) #5

Lol, @Jon_Gordon , yeah I know- but it was just to indicate which was which easier. I had 4 screenshots that I had up to compare on my desktop. Sheesh:) I will try and refrain from such time/space saving craziness in the future. Your sentence structure for that comment wasn’t too solid, by the way (BTW). Didn’t bother me though.:slight_smile: Cheers!

(Jon Gordon) #6

Sorry, I should have put a “jk jk lol” on there for you.

Just thought it was funny is all.

(boog nish) #7

Heh, totally! Thanks for taking the time to look though. Every bit of help from this community is greatly appreciated. I abbreviate file names on my desktop regularly. I can understand your dismay though. I am often saddened and “killed” by how far language, communication, spelling etc. has gone downhill due to the general acceptance of such things. Have a good one.

(David Wille) #8

The right on the mark buddy. Your going to want to set in software that you don’t have a heated bed. Whether it has a setting in the software that should take care of it, or have to write it into the gcode manually.

Tip: always remember, most software, will not override your changes to G code. Especially for bed/Fan/heat element commands.

So even if you set software to “no bed” and have a command in gcode to set temp at 0, it will still attempt to do the later.

Setting temp to 0 should be whata wrong. Makes the board think you have a heated bed and that it needs to set bed to 0°. And is therefore hanging up on ya there I think.

Your going to want to make sure software knows you don’t have a bed. And if there isn’t an option for this, then just take the command out of the gcode completely. That way there isn’t anything there for it to read and then attempt to do.

That’s how I had my printrbot set up prior to installing my hearing bed upgrade.

But then, once I purchased & installed the bed I changed the gcode to heat up the bed before starting to print. I can’t remember if repitier has the option in it to set if you have a bed or not, which is why i believe i was putting it in gcode in the first place.

I think that’s your problem though buddy, your going to want to take it out of the gcode so it doesn’t try talking to something not there. You should be good to go then with just doing that, meaning just remove the command for setting the temp and waiting for it to reach the temp point. Also to be safe remove any input you’ve placed in the software side, unless it actually has an area for you to define if there is a bed or not. If there is a spot to do so, I would do that and still remove the commands entered In the gcode. Should be golden then.

I do use Cura now (I prefer its slicing over slic3r) and it has software controls built in to set if you have a bed or not, so its not necessary to have to put it in the gcode yourself. You can place it in there to run your own custom generated gcode for prints, ie. To change the temp higher or lower for first layers/raft/making start and stop points for single extruders/etc. Cura has great manual controls in the software to control this before,during, or after printing though for basic functions while printing so its not necessary in case of redundancies in your gcode.

(David Wille) #9

Ps. I see in the code there it says
“m190 s5” meaning set temp to 5° for bed

That should deff be Del outta there!

(boog nish) #10

@David_Wille , Yep. That’s what I thought. I just need to figure out how to get rid of it altogether. Setting ‘default bed temp’ to 0 in my printer settings doesn’t seem to do anything though. Still generates ‘M190 S5’. I have just gone and manually deleted that line out of the Gcode and it runs the job! So is there a way (maybe the 'M190 S0 and then M500?) that will make it so ythat it applies to everything from this point on?

(boog nish) #11

…and I just saw your previous comment… All makes sense, thanks so much- but still thinking that I can make it gone permanently somehow. After all it used to not even be there. I think that I am either missing the spot in Repetier or that I need to do the M commands and saves that I proposed above.

(David Wille) #12

My fault buddy i completely forgot to add that in to the explanation, left that out completely. You should be able to write the command into an area that set a custom code in with your sliced gcode every time it runs to generate. Your exactly right, m500 sets to save it in the board to keep it on there for running said code each time it prints + with the generated sliced code.

Cura has a gcode editer front and center that saves to the profile , basically to do eaxctly what your talking about. Sorry havwnt had to make changes/run custom stuff for a few weeks so that totally slipped my mind :-/.

(Currently starting a small business right now and have been really hars hitting the books of html/php/mysql stuff to refresh the brain while building the site and backend stuff, terrible condition of being a programmer lol, have multiple code types/commands/etc running around in my head all the time!)

(boog nish) #13

Thanks @David_Wille , I’m so close to getting this resolved- I just am familiar with Repetier vs Cura and I don’t know that I am ready to make the switch right now. Perhaps soon. I am going to try to accomplish this in repetier with 2 different ways and see if either does the trick.

(boog nish) #14

O.K… I have found where I can custom edit Gcode via ‘Printer settings’ in Slic3r. However It seems that I can only ADD commands and what I want to do is eliminate the M190.

(David Wille) #15

Go to the settings box where you originally put the value in for a heated bed. Change the box so that there is no value in it. Apply changes. That should make the slicer stop putting the code into your generated sliced gcode.

Test by slicing a new object. I think this will do it.

(David Wille) #16

When you enter gcode changes into the terminal. Your just chsnging the settings at that point in time for the board.

The problem is, whenever you slice something, it makes new code with the parameters you have set in the software. So you need to change the box where you entered the value for the heated bed i believe.

(David Wille) #17

Where you see the custom add code part, that is like you said, am area you can write gcode scripts into and select them to run when you print/Cam be helpful for more advanced controlling of your printer, in future.

However, there should be an area for slicer settings that has a similar area for entering gcode to use when slicing. There maybe an oprion there for the heated bed as well, or it has a gcode script box there too and has the heated bed command in it due to the setting change,

I think. Check that out.

If this doesn’t help, ill grab repetier and download it again and figure this out right for ya.

(David Wille) #18

Once the setting has been deleted so there is nothing in it. That should stop the command from being generated into gcode when you slice something.

(Nathaniel Stenzel) #19

http://manual.slic3r.org/simple-mode/simple-mode#filament-settings
If you have the bed temperatures set to 0 and you still see it waiting for the heated bed, you may be a victim of a bug from 2013? That would be weird.

(Nathaniel Stenzel) #20

DING DING DING!
Read This!


Ignore the fact that it starts off talking about end stops and just read it. You will find your answer in the 2-3 paragraghs before the picture towards the bottom.