After changing from the stock k40 board to the grbl board I'm get random

gplus
(Chris X) #1

After changing from the stock k40 board to the grbl board I’m get random dots. I’ve changed acceleration, re worked the image from scratch and steps per mm.

(Akai Coit) #2

Have you run the process more than once and the dots appear in different places each time or the same places each time?

(Chris X) #3

@CPUnltd yes about 30 times now trying different settings. Always in different spots. It seems like they are always next to an engraved portion. They are rarely in the Middle

(Akai Coit) #4

What about more than once with the same settings? Did the dots still come out in “random” locations or were they consistent?

(LightBurn Software) #5

What software are you using to generate the GCode? Are you telling that software to dither, or threshold when outputting?

(Chris X) #6

@LightBurn_Software laserweb and light burn. I’ve tried greyscale, black and white, and threshold.

(Chris X) #7

@CPUnltd yes. Dots are random. Always seem to be right next to the engraved portions. Almost as if sometimes fireing a bit to early

(Akai Coit) #8

Initial thought is a glitch in the code it’s executing. Never used that software and board. But if you can debug the code that’s being ran, it could give you answers.

(Chris X) #9

Well I feel rediculous. Only after changing my computer’s display settings and zooming all the way in was I finally able to find the whole image was covered in 1 or 2 shades of of white pixels! Got it cleaned up and it’s good to go! Thanks for your help!

(Akai Coit) #10

Glad you were able to get the issue resolved. :slight_smile:

(Kelly Burns) #11

@Chris_X What would be ridiculous is if you didn’t come back and report the actual problem. I have seen this same issue posted before. So you were not alone. Thanks for posting back.

(Chris X) #12

Well what I thought was solved is not. Both vector images and raster still producing the same dots. I’ve installed a resistor and cap on the PWM line for a noise filter and still no result :disappointed_relieved:

(Chris X) #13

Looks like the problem is tied to the $28 setting of 0(default) and other high frequency settings. Upon changing it to 5 or 6 the dots are eliminated. Any insight as to why?

(LightBurn Software) #14

You initially said “the grbl board”, not “the Gerbil board” - the $28 setting is a custom setting for that version of GRBL only, which would’ve been good to know at the beginning. Not all power supplies respond well to higher frequency PWM signals, so changing the period can help, which is what that specific version of GRBL does with $28.

(Chris X) #15

@LightBurn_Software I apologise for this misunderstanding. I’m currently rewiring with all shielded cables. Hopefully this will resolve it.