After a long time I continued with my chinese CNC1610.

After a long time I continued with my chinese CNC1610.

  • Installed stock GRBL 1.1f on the Woodpecker pcb
  • Added limit/homing switches
  • Tested z-probing
  • Able to use it with ChiliPeppr jpadie

It turns out that the Woodpecker pcb that is part of the kit contains an Arduino Nano with bootloader. So I installed GRBL from and it runs perfectly fine.

And: the Woodpecker CNC has a connector where most of the Arduino pins are available. Pictures below show how I used these to connect limit/homing switches to the machine.

The Arduino A5 pin is also available on the connector to mount a cheap chinese probe, which also works nicely.

Still having to get more experience with real processing, but the basic machine is now almost ready to go. Hope this gives others some inspiration!

Thanks. I have the same machine but didn’t have the time yet to add limit switches yet.
But I added a Raspberry PI to the back which runs SerialJSONServer. I 3D printed a custom mount for it.

Hopefully someone can be of help. It seems the /jpadie environment changes the grbl $13 parameter from 0 to 1 (report in inches) when I connect my machine. How can this be prevented?

By pressing the mm button on the top right.

Well, the top right positions mentions ‘mm’, but it is shown in inches. Changing parameters on connect seems undesired to me.

If the unit mode is set to “mm” with G21 the workspace detects it and sends automatically an “$13=0”. If you switch to inches with G20 then it sends “$13=1”

This was the wrong way around in the past and this was fixed recently by jpadie with this commit:

But the change somehow does not appear in the generated workspace on (I checked it with Chrome inspector, it is still the old code)

Pinging @Justin_Adie

how did you add the probe to the woodpecker board? and what did you use to load the firmware to the board? I tried XLoader but it fails.